アーカイブ

6rd設定方法(Cisco IOS編)

さくらの6rd(トライアル)>6rd設定方法(Cisco IOS編)

ここでは、Cisco IOSにおける6rdの設定方法について説明します。
※ 設定前にトップページの「提供条件」を必ずお読みください。

CiscoのIOSでは、バージョン15.1(3)Tより6rdがサポートされました。参考までにリリースノートのURLを以下にリンクします。
http://www.cisco.com/en/US/prod/collateral/iosswrel/ps8802/ps10587/ps10592/ps11296/product_bulletin_c25-635704.html

ネットワーク構成例

例として、以下のようなネットワークを取り上げます。グローバル側(fa0)にIPv4アドレス59.106.69.121が設定されたCisco1812JのLAN側インターフェイス(fa1)に、6rd経由で使用可能なIPv6アドレスを設定します。

6rdの設定を行う

使用可能なIPv6アドレスを、Linux等のシェル上で以下のように入力してあらかじめ算出しておきます。IPv4アドレスをスペース区切りで引数に指定してください。

# printf "2001:e41:%02x%02x:%02x%02x::1\n" 59 106 69 121
2001:e41:3b6a:4579::1

設定は以下の通りです。青文字の部分はそれぞれの環境に合わせて書き換えてください。

ipv6 unicast-routing

interface Tunnel0
 no ip address
 no ip redirects
 ipv6 unnumbered FastEthernet1
 ipv6 mtu 1280
 tunnel source FastEthernet0
 tunnel mode ipv6ip 6rd
 tunnel 6rd prefix 2001:e41::/32
 tunnel 6rd br 61.211.224.125

interface FastEthernet0
 ip address 59.106.69.121 255.255.255.224

interface FastEthernet1
 ipv6 address 2001:e41:3b6a:4579::1/64

ip route 0.0.0.0 0.0.0.0 59.106.69.97

ipv6 route 2001:e41::/32 Tunnel0
ipv6 route ::/0 2001:e41:3dd3:e07d::1

※ 各設定の意味は、過去のブログ「6rdによるIPv6接続(Cisco編)」を参照ください。

設定反映を確認

設定を行った後、きちんと反映されているかどうか、まずは以下のコマンドで確認します。

cisco1812j-6rd#show tunnel 6rd
Interface Tunnel0:
  Tunnel Source: 59.106.69.121
  6RD: Operational, V6 Prefix: 2001:E41::/32
       V4 Prefix, Length: 0, Value: 0.0.0.0
       V4 Suffix, Length: 0, Value: 0.0.0.0
       Border Relay address: 61.211.224.125
  General Prefix: 2001:E41:3B6A:4579::/64

青文字の部分に誤りがないか確認します。なお、General Prefixは、自身で使用可能なIPv6アドレス空間が自動的に計算されて表示されます。

続いてルーティングテーブルを確認します。6rdに関する経路を青文字で以下示します。

cisco1812j-6rd#show ipv6 route
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       D - EIGRP, EX - EIGRP external, NM - NEMO, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S   ::/0 [1/0]
     via 2001:E41:3DD3:E07D::1
S   2001:E41::/32 [1/0]
     via Tunnel0, directly connected
C   2001:E41:3B6A:4579::/64 [0/0]
     via FastEthernet1, directly connected
L   2001:E41:3B6A:4579::1/128 [0/0]
     via FastEthernet1, receive
L   FF00::/8 [0/0]
     via Null0, receive